Ik wil in Excel een reeks getallen optellen, maar hij geeft 0, hoe kan dit?

Ik gebruik bij het optellen van de reeks de formule =SOM(...)
De getallen die in deze reeks staan, zijn verkregen door deze formule:
=ALS(EN(B5="KLEIN";C5="V");"12";ALS(EN(B5="KLEIN";C5="B");"9";ALS(EN(B5="GROOT";C5="V");"13";ALS(EN(B5="GROOT";C5="B");"10";"FOUT"))))

Als uitkomst geeft hij 0.

Hopelijk kan iemand mij hier mee helpen!!

Alvast bedankt!

Weet jij het antwoord?

/2500

Als je =SOM hebt gedaan, moet je daarna nog haakje openen getal 1 puntkomma getal 2 enzovoorts. Dat ziet er dan zo uit: (getal1;getal2;getal3). Je kan ook als je bijvoorbeeld rij A wilt optellen A1+A2+A3 enzovoorts doen.

De uitkomst van de formule is zo te zien 12, 9, 13, 10, of "FOUT". Het probleem is dat je de formule zo hebt geschreven dat de uitkomst niet (bijvoorbeeld) 12 is, maar "12". 12 is een getal, maar "12" is een tekst. De formule SOM(...) kan getallen optellen, maar geen teksten. Jij bent nu bijvoorbeeld "12", "13", nog een keer "12" en "9" bij elkaar aan het optellen. Dat zijn allemaal teksten. SOM(...) ziet een tekst als 0. Je bent dan dus vier keer 0 aan het optellen, en dat is inderdaad 0. De oplossing is de aanhalingstekens rond de getallen weg te halen. In bovenstaand voorbeeld tel je dan niet meer "12", "13", "12" en "9" (vier teksten) bij elkaar op, maar 12, 13, 12 en 9 (vier getallen). En dat levert het verwachte resultaat.   Toegevoegd na 2 minuten:   Laat ik het wat concreter opschrijven: verander je formule in =ALS(EN(B5="KLEIN";C5="V");12;ALS(EN(B5="KLEIN";C5="B");9;ALS(EN(B5="GROOT";C5="V");13;ALS(EN(B5="GROOT";C5="B");10;"FOUT"))))  

Je hebt de getallen 12,9,13 en 10 tussen quotes (") gezet. De uitkomst is dus geen getal, maar tekst. En als je geen getallen optelt krijgt je 0 als totaal. Quotjes weghalen dus.

Stel zelf een vraag

Ben je op zoek naar het antwoord die ene vraag die je misschien al tijden achtervolgt?

/100