Is MySQL4 nog wel veilig?

Aangezien volgens Wikipedia er al zeker versie 5.4.1 bestaat... Is 't nog wel verstandig een forum nog op versie 4 (2007?) te draaien? Of kan dan makkelijk met een remote attack bijv. de user-database worden leeggezogen?

Dit n.a.v. deze error op tr.im/goeie:

General Error
SQL ERROR [ mysql4 ]

Can't connect to MySQL server on 'sbuh.sagavi.colocated.redunix.net' (4) [2003]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Weet jij het antwoord?

/2500

Het beste antwoord

MySQL 4.1 zit qua 'levenscyclus' nu in de "Extended Lifecycle period". Dat houdt in dat veiligheidslekken en de ergste bugs nog worden verholpen. MySQL 4.1 is dus nog wel redelijk veilig. Niettemin is het altijd aan te raden om de meest recente versie van een software-product te gebruiken. De genoemde "Extended Lifecycle period" van MySQL 4.1 eindigt op 31 december 2009 (over ruim een maand dus). Vanaf dat moment valt het zeker aan te bevelen om over te stappen op een recentere versie.

Bronnen:
http://www.mysql.com/about/legal/lifecycle...

Stel zelf een vraag

Ben je op zoek naar het antwoord die ene vraag die je misschien al tijden achtervolgt?

/100