kan ik een werkblad beveiligen zodat de formule niet berekend word zodra 1 cel waar de formule naar verwijst leeg is ?

Weet jij het antwoord?

/2500

Het beste antwoord

Ten eerste: ik neem aan de je het over Excel hebt. Ten tweede: werkblad beveiligen betekent in Excel waarschijnlijk wat anders dan dat je bedoelt. Werkblad beveiligen betekent dat niet iedereen zomaar alles kan bewerken in het door jouw gemaakt werkblad. En dan nu antwoord op je vraag: Stel dat je in cel C1 de formule B1/A1 hebt staan en je wilt niet dat deze berekend wordt wanneer A1 leeg is. Je kunt dan in C1 de volgende formule plaatsen: =ALS(ISLEEG(A1);"";B1/A1) Je kunt ook de functie ISFOUT gebruiken. Stel je hebt een ingewikkelde formule in cel C1 en je wilt dat wanneer deze niet berekend kan worden dat er niks in C1 komt te staan, dan kun je de formule in C1 vervangen door: =ALS(ISFOUT(formule;"";formule) Hierin moet je formule nog vervangen door jouw formule. Bijvoorbeeld: =ALS(ISFOUT(wortel(A1)/wortel(B1);"";wortel(A1)/wortel(B1)) Toegevoegd na 2 minuten: Ik zie dat ik niet zorgvuldig ben geweest met de haakjes: Herstel: =ALS(ISFOUT(formule);"";formule) =ALS(ISFOUT(wortel(A1)/wortel(B1));"";wortel(A1)/wortel(B1)) Toegevoegd na 5 minuten: Nog een opmerking: In plaats van "" kun je ook iets anders zetten. Het is hetgeen Excel laat zien in C1 in het geval van een fout. Je kunt dus ook zetten: =ALS(ISFOUT(wortel(A1)/wortel(B1));"ONGELDIG";wortel(A1)/wortel(B1)) of =ALS(ISFOUT(wortel(A1)/wortel(B1));9999999;wortel(A1)/wortel(B1))

Dat is niet een kwestie van het werkblad beveiligen, maar van de formule juist definiëren. Je moet daarvoor de formule wat uitgebreider maken. Gebruik de ALS-functie: ALS die cel groter dan nul is DAN moet je de formule invullen ANDERS moet je een spatie invullen, waardoor de cel met de formule leeg is/lijkt. Voor het exact formuleren van de ALS-functie verwijs ik je naar Excel, die geeft dat duidelijk aan in het schermpje waarin je de formule maakt. Succes!

Bronnen:
Zo doe ik het zelf altijd.

Stel zelf een vraag

Ben je op zoek naar het antwoord op die ene vraag die je misschien al tijden achtervolgt?

/100