Excel: hoe werkt de "vertikaal-zoeken-formule"?

Voor een administratie (export vanuit ING) heb ik een groot overzicht van uitgaven. Bijvoorbeeld bij de Lidl, maar bij verschillende vestigingen:

Lidl 165 Vlaardingen VLAARDINGEN
Lidl 535 Vlaardingen VLAARDINGEN

Nu gebruik ik een functie om via vert.zoeken in een 2e tabblad het label 'Boodschappen' aan deze uitgaven toe te voegen. Echter bij het zoeken in de lookup-tabel gaat deze op zoek naar een exact match. Ik moet in die tabel dus toevoegen:

Uitgave Label
Lidl 165 Vlaardingen VLAARDINGEN Boodschappen
Lidl 535 Vlaardingen VLAARDINGEN Boodschappen

Maar eigenlijk wil ik dat in 1x alles wat begint met Lidl -> het label boodschappen meekrijgt.

Ik gebruik nu deze formule om de winkel 1:1 te machten met het uitgaven label:

=ALS.FOUT(VERT.ZOEKEN("*"&F52&"*";Blad2!$A$2:$B$120;2;ONWAAR);"Overige")

Waar F52 de uitgave is en op blad 2 in een tabel tussen A2 en B120 de match wordt gezocht tussen uitgaven en label. De Als.fout vergelijking zorgt ervoor dat als het niet gevonden wordt er een label 'overige' wordt toegevoegd.

LOOKUP Tabel:
Type uitgave Te gebruiken label
Lidl 165 Vlaardingen VLAARDINGEN Boodschappen
Lidl 535 Vlaardingen VLAARDINGEN Boodschappen

Thanks

Weet jij het antwoord?

/2500

Je kunt een VERT.ZOEKEN formule gebruiken als je zoekt op de eerste 4 karakters, dus in dit geval 'Lidl'. De formule wordt dan: =VERT.ZOEKEN(LINKS(A1;4);tabel;kolomnr;ONWAAR)

Stel zelf een vraag

Ben je op zoek naar het antwoord die ene vraag die je misschien al tijden achtervolgt?

/100