Hoe maak ik de volgende Excel formule?

Als a1 = appels --> laat zien: A
Als a1 = peren --> laat zien: B
Als a1 = bananen -- > laat zien: c
etc.

Weet jij het antwoord?

/2500

Het beste antwoord

Bovenstaand antwoord is helemaal waar. Echter, de geneste als-functies kunnen al snel onoverzichtelijk worden, zeker als je heel veel mogelijkheden hebt. In dat geval kun je overwegen een hulptabel (bijvoorbeeld op een ander blad) te maken en met de functie "verticaal zoeken" (VERT.ZOEKEN) een waarde op te halen uit de hulptabel. Je krijgt dan op blad2 de tabel Kolom A Kolom B Appels A Peren B Citroenen C Bananen D Druiven E Mango's F Sinaasappels G ... En op je hoofdblad: in cel A1: Druiven in cel B1: =vert.zoeken(A1;Blad2!A:B;2;ONWAAR) Je zult zien dat in cel B1 de waarde "E" komt te staan.

=ALS(A1="appels";"A";ALS(A1="peren";"B";ALS(A1="bananen";"C"))) Toegevoegd na 4 minuten: De formule is als volgt opgebouwd: =ALS(logische-test;[waarde als waar];[waarde als onwaar]) Omdat het tekst is, zet je het tussen " ". Vervolgens kun je bij de [waarde als onwaar] weer een nieuwe ALS voorwaarde instellen en zo maar doorgaan. Let wel dat je aan het eind genoeg sluitende haakjes hebt.

Stel zelf een vraag

Ben je op zoek naar het antwoord die ene vraag die je misschien al tijden achtervolgt?

/100