Waarom voert excel soms een 12e decimaal toe bij optellen van 2 gebroken getallen?

als ik de volgende getallen optel, wordt er opeens een extra 12e decimaal bijgevoegd (de berekende waarde komt daardoor niet meer overeen met de ingevoerde waarde)
waardoor komt dit ?

-6.463,1900000000000
6.902,3100000000000
439,1200000000010

Weet jij het antwoord?

/2500

Het beste antwoord

Een computer kan gehele getallen met oneindige preciesie opslaan. Bij gebroken getallen (getallen met cijfers achter de komma) lukt dat echter in het algemeen niet. Daardoor worden gebroken getallen vrijwel altijd net iets anders opgeslagen dan je ze invoert. Excel zorgt er intern voor dat je daar meestal niets van merkt, maar soms komt dit feit toch aan de oppervlakte. Jij hebt zo'n geval gevonden. Wat je eraan kunt doen is zelf het resultaat afronden. Als je weet dat de eerste zes decimalen genoeg zijn, kun je bijvoorbeeld de huidige formule       =A1+A2 vervangen door       =AFRONDEN(A1+A2; 6) Excel zal in dit geval het resultaat van de berekening A1+A2 afronden op zes decimalen; in plaats van 439,1200000000010 komt er dan 439,120000 uit, en dat zal door Excel als 439,12 worden getoond.  

selecteer de kolom of de cellen en klik op je rechtermuisknop cel eigenschappen daarna kies getal en maak de decimalen 2 probleem opgelost.

Stel zelf een vraag

Ben je op zoek naar het antwoord die ene vraag die je misschien al tijden achtervolgt?

/100